Forums now use SSL

mike_israel

Amphicar Forum Admin
Staff member
Hi All,

Latest update to the forums is the addition of SSL encryption. If you are really observant, you may have noticed the little lock icon that now appears next to the url in your browser.

If you encounter any problems, please let me know.

You can also thank Dave the Wave for this latest enhancement. Dave recently made a donation to the forums so that prompted me to do this update. All donations ultimately make their way back to supporting or enhancing this service. Adding SSL increases the operating costs of the forums by another $40 a year (SSL certificate plus dedicated ip address). It's all a part of providing a great (and secure) experience. Thanks to all those who help keep it afloat. If $$ are tight, no worries, make a contribution by sharing your knowledge with other members.

Mike

More on SSL here:

SSL is the technology used to encrypt communication between your computer and the website you’re visiting, and to ensure trust (the certainty that the website you’re on is who they say they are). This allows sensitive information such as banking details, usernames and passwords, and private conversations to be securely exchanged between your computer and the website without risk of attackers viewing or stealing that information.
 

strandweiss62

Active Member
Do you think it is really necessary to use SSL with a public forum?
OK, it may be better for members which use the same password for all their activities in the net.

Peter
 
Top