Electrical problem

Oldstang

New Member
Little help please. Went to start after sitting about 2 hours and battery was dead, push started with no problem, turned headlights on motor died. Towed home the next morning charged battery car started up and ran fine with headlights on. Has anyone had this problem? How many volts should the generator be putting out?
Thanks Dave
 

Midwest Amphicar

Worlds Largest Amphicar Destination
I dont fiddle too much with the old generator but 13.8 max comes to mind. Follow large red wire to junction block near muffler. That is your main feed. They get corroded and loose. I highly suggest adding a high amp fuse like 50 amps. Because this is a non fused hot wire that goes into dash. Cars have caught fire due to this.
If you have original bak-o lite (plastic) pulley on generator find a metal one. If your car is original plan on some time replacing the wire connectors at junction block and regulator- do not forget the wire at generator. That one is almost always loose. The brass gets brittle and than becomes loose. If in northern Illinois or at times in central Florida stop and visit. Later Gator Wave
 

SNOWBIRD

Amphicar Expert
Your not charging.
I install a underdash volt meter on my cars.
as long as Generator is over 12 and under 14 when at speed Im happy, Usually 12 when headlight are on.
Most times its the voltage reg, giving prblems but test generator first,
The manual tells what wires to do what with, I have to read each time I test.
and yes make sure all connections are good and clean etc.
I bounce back and forth to Florida too.Will head down at end of month for a month. Looking for a house with a garage or should I say a Garage with a house.Rons down now at my Moblie home place,with all the parts.Problem there is theres no place for both of us to park all our toys(cars)
In the Mt Dora ,Leesburg area (lots of lakes)the there are 5 winter Amphicar owners! plus all the full time residents within 50 miles(lots)
 
Thread starter Similar threads Forum Replies Date
CapnJohn Odd electrical problem General Amphicar Discussion 3
Tom Laferriere Electrical Problem driving me crazy! General Amphicar Discussion 25
M Electrical Problem General Amphicar Discussion 0
Jon March Q re: the electrical "connector rail" / barrier / connector strip General Amphicar Discussion 8
mike_israel Guide to electrical relays General Amphicar Discussion 0
D electrical repair General Amphicar Discussion 1
B Electrical questions General Amphicar Discussion 1
M Electrical question General Amphicar Discussion 3
W Electrical Question/Help General Amphicar Discussion 2
M Electrical help for Chuck General Amphicar Discussion 1
C BIG Problem with tachometer cabling General Amphicar Discussion 1
Propcar50 Horn Problem Revisit General Amphicar Discussion 2
jean-marie problem with pounding noise in gearbox while driving General Amphicar Discussion 13
mike_israel Problem with duplicate postings on Amphicar forum General Amphicar Discussion 6
Midwest Amphicar Intermittent fuel problem solved General Amphicar Discussion 2
mike_israel Amphicar Forum Problem Resolved General Amphicar Discussion 0
T New G.Imports Chrome Headlight Trim Ring Problem??? General Amphicar Discussion 1
mike_israel Unusual Forum Problem? General Amphicar Discussion 1
G Spot the problem. General Amphicar Discussion 5
F fuel flow problem General Amphicar Discussion 2
W running problem update General Amphicar Discussion 2
W RUNNING PROBLEM General Amphicar Discussion 4
J Water Tranny Problem General Amphicar Discussion 1
T Front Wheel: Seal Install Problem General Amphicar Discussion 2
T Front Wheel Bearing problem General Amphicar Discussion 2
T WATER PUMP PROBLEM: General Amphicar Discussion 2
C Problem Solved! General Amphicar Discussion 4
L Prop Shaft Removal Problem (was Noisy Prop Shaft Tubes) General Amphicar Discussion 2
K Carb problem General Amphicar Discussion 0
R Me again! Starter problem... General Amphicar Discussion 0
B Wiper Problem Solved General Amphicar Discussion 4
D Speedometer Problem General Amphicar Discussion 2
T Problem with Front wheel Berring General Amphicar Discussion 3
A amphicar.com siet problem update... General Amphicar Discussion 0
M door latch problem General Amphicar Discussion 0
M Wandering problem solved.........again General Amphicar Discussion 3
A Radiator Problem General Amphicar Discussion 14
P Amphicar Nightmare Update / Clutch Problem in First Gear General Amphicar Discussion 2
B Accelerator/Clutch Problem General Amphicar Discussion 1
S Ebay- rear brake cylinder problem General Amphicar Discussion 0
M Problem with Insurance General Amphicar Discussion 4
R convertible top problem General Amphicar Discussion 5
M Engine Mount Problem General Amphicar Discussion 2
B From Bilgemaster: You might have a virus problem... General Amphicar Discussion 0
A clutch problem General Amphicar Discussion 3
A HEADLIGHT PROBLEM General Amphicar Discussion 0
K Problem with HP muffler on early cars General Amphicar Discussion 3
D starting problem General Amphicar Discussion 4
B Starter Problem General Amphicar Discussion 6
G Starter/Solenoid problem General Amphicar Discussion 4
Similar threads


















































Top