clutch trouble

  • Thread starter antique459@aol.com
  • Start date
A

antique459@aol.com

Guest
Hi All,
I am just at a loss as to what may be wrong. I had my clutch redone
and I bought a new cable and throwout bearing. I installed everything
and I cannot seem to disengage the cluth to put the car in gear. If
anyone has had this experience and knows what I am doing wrong your
help and advice will be GREATLY appreciated. One thing that I was
advised was to reposition the "triangle" but that did not help.

I can tell you that the fork seems to travel to almost half way
before I can feel the throwout bearing touch the pressureplate is
that normal?? When I do step on the clutch it seems you have to be
Hercules to get it to go down any.

Another problem I am havibg is that after rebuilding my master
cylinder I have fluid leaking out the back by the boot..any
suggestions??
Thanks,Keith
62 and I am blue!
 
R

richard martin

Guest
I had that happen to me last year, I removed the motor and took the clutch
housing apart and found the clutch stuck on , i remved and cleaned it and
reasembled it and it seems to be OK martin@discover-net.net
----- Original Message -----
From: <antique459@aol.com>
To: <amphicar-lovers@yahoogroups.com>
Sent: Monday, July 09, 2001 6:08 PM
Subject: [amphicar-lovers] clutch trouble


> Hi All,
> I am just at a loss as to what may be wrong. I had my clutch redone
> and I bought a new cable and throwout bearing. I installed everything
> and I cannot seem to disengage the cluth to put the car in gear. If
> anyone has had this experience and knows what I am doing wrong your
> help and advice will be GREATLY appreciated. One thing that I was
> advised was to reposition the "triangle" but that did not help.
>
> I can tell you that the fork seems to travel to almost half way
> before I can feel the throwout bearing touch the pressureplate is
> that normal?? When I do step on the clutch it seems you have to be
> Hercules to get it to go down any.
>
> Another problem I am havibg is that after rebuilding my master
> cylinder I have fluid leaking out the back by the boot..any
> suggestions??
> Thanks,Keith
> 62 and I am blue!
>
>
> To unsubscribe from this group, send an email to:
> amphicar-lovers-unsubscribe@egroups.com
>
>
>
> Your use of Yahoo! Groups is subject to http://docs.yahoo.com/info/terms/
>
>
 

Similar threads


Top